Лекция. Использование объемного эффекта

Используя объемный эффект, можно управлять оформлением объемных изображений с помощью освещения, теней, вращения и других атрибутов. В этой части урока вы используете двухмерные фигуры в качестве основы для создания трехмерных объектов.

Существуют три типа объемных эффектов, которые вы можете применить:

• Extrude & bevel (Вытягивание и скос) — двухмерные объекты вытягиваются вдоль оси Z, что добавляет объектам глубину. Например, эллипс становится цилиндром;

• Revolve (Вращение) — для создания трехмерного объекта контур или профиль поворачивается вокруг глобальной оси Y (оси вращения);

• Rotate (Поворот) — двухмерное изображение поворачивается в трехмерном пространстве относительно оси Z, что изменяет перспективу изображения.
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Создание трехмерного объекта вращением

В этой части урока вы познакомитесь с одним из объемных эффектов, который называется Revolve (Вращение). С помощью данного эффекта вы создадите банку для содовой воды, используя существующий контур во второй монтажной области.

1 Выполните команду Window ⇒ Workspace ⇒ Essentials (Окно ⇒ Рабочая среда ⇒ Основные сведения).

2 Щелкните по значку палитры Artboards (Монтажные области) , чтобы развернуть эту палитру.

3 Дважды щелкните в палитре по монтажной области 2, чтобы подогнать ее по размеру окна документа. Сверните палитру Artboards (Монтажные области).
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4 Выполните команду меню Select ⇒ All On Active Artboard (Выделение ⇒ Все объекты в активной монтажной области). Этот контур представляет собой половину фигуры банки для содовой. При применении к контуру эффекта Revolve (Вращение) будет выполнено вращение контура вокруг правого или левого края, в результате чего вы получите фигуру с охватом 360°.

5 На панели Control (Управление) щелкните по кнопке Stroke (Обводка) и выберите образец None (Нет) .

Примечание. При вращении объекта цвет обводки переопределяет цвет заливки.

6 Щелкните по кнопке Fill (Заливка) На панели Control (Управление) и выберите белый цвет.

7 Выполните команду Effect ⇒ 3D ⇒ Revolve (Эффект ⇒ Объемное изображение ⇒ Вращение). Откроется диалоговое окно 3D Revolve Options (Параметры вращения 3D-изображения). В раскрывающемся списке Position (Положение) укажите вариант Front (Передний план). Установите флажок Preview (Просмотр) для отображения изменений. При необходимости переместите диалоговое окно, чтобы видеть иллюстрацию.

Примечание. В зависимости от сложности вращаемой фигуры и производительности компьютера изменение параметров в диалоговом окне 3D Revolve Options (Параметры вращения 3D-изображения) может происходить с определенной задержкой. В таком случае сбросьте флажок Preview (Просмотр), выполните несколько изменений, после чего снова установите флажок. Таким образом, фигура не будет перерисовываться на монтажной области после каждого изменения.

Совет. Параметр Angle (Угол) задает значение угла, на который необходимо выполнить вращение. Вы можете установить значение меньше 360°, если хотите создать изображение объекта в разрезе.

8 Для параметра Offset From (От) выберите вариант Right Edge (Правого края). Это край, вокруг которого будет выполнено вращение контура. Полученный результат в значительной степени будет определяться тем, какой край фигуры вы выберете, и тем, применена к исходному объекту обводка или заливка. Щелкните по кнопке OK.
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9 Выполните команду меню File ⇒ Save (Файл ⇒ Сохранить). Оставьте файл открытым.

Параметры объемного вращения

Диалоговое окно 3D Revolve Options (Параметры вращения 3D-изображения) содержит еще несколько параметров, о которых стоит упомянуть:

• Angle (Угол) устанавливает угол в градусах для вращения контура, от 0 до 360;

• Cap (Концы) определяет, должен ли объект выглядеть сплошным: Revolve Cap On (Отображать торец), — или пустотелым: Revolve Cap Off (Не отображать торец);

• Offset (Сдвиг) добавляет расстояние между осью вращения и контуром для создания кольцеобразных объектов. Можно указать значение от 0 до 1000.

Изменение освещения трехмерного объекта

Эффект Revolve (Вращение) позволяет добавить один или несколько источников света, варьировать интенсивность освещения, изменять цвет тени объекта и перемещать вокруг него источники света.

В этой части урока вы измените интенсивность и направление освещения.

1 Убедитесь, что фигура банки для содовой по-прежнему выделена. Щелкните по имени эффекта 3D Revolve (Вращение 3D-изобра жения) в палитре Appearance (Оформление). Если эта палитра

не отображена, выполните команду меню Window ⇒ Appearance (Окно ⇒ Оформление). Возможно, вам потребуется прокрутить палитру или изменить ее размер для более удобного просмотра.

2 В диалоговом окне 3D Revolve Options (Параметры вращения 3D-изображения) установите флажок Preview (Просмотр) и щелкните по кнопке More Options (Больше). Вы можете создать пользовательские эффекты освещения для трехмерного объекта. Используйте область предварительного просмотра в левой нижней части диалогового окна, чтобы изменить положение источника света и цвет тени объекта.

3 Укажите в раскрывающемся списке Surface (Поверхность) вариант Diffuse Shading (Размытая тень).

4 В области предварительного просмотра, содержащей изображение затененной сферы, перетащите влево белый квадрат, представляющий собой источник света. При этом изменится направление освещения. Щелкните по кнопке New Light (Новый источник света) , чтобы добавить еще один источник света. Перетащите второй источник света вниз и вправо. Попробуйте использовать другие варианты расположения. Сместите диалоговое окно в сторону, чтобы видеть изменения на монтажной области.
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5 В раскрывающемся списке Shading Color (Цвет тени) отметьте пункт Custom (Заказной). Щелкните по красному квадрату справа от слова Custom (Заказной). Откроется диалоговое окно Color Picker (Палитра цветов). Измените цвет на серый (C = 0, M = 0, Y = 0, K = 50). Щелкните по кнопке OK, чтобы закрыть диалоговое окно Color Picker (Палитра цветов) и вернуться в диалоговое окно 3D Revolve Options (Параметры вращения 3D-изображения).

6 Задайте для параметра Light Intensity (Интенсивность освещения) значение 80%, а для параметра Ambient Light (Окружающее освещение) — 10%. Не закрывайте диалоговое окно. Параметр Ambient Light (Окружающее освещение) управляет общей яркостью поверхности трехмерного объекта.
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Примечание. В зависимости от производительности компьютера для обработки изменений в диалоговом окне 3D Revolve Options (Параметры вращения 3D-изображения) может потребоваться некоторое время.

7 Измените значение параметра Blend Steps (Шагов перехода) на 40 и щелкните по кнопке OK.

8 Выполните команду меню File ⇒ Save (Файл ⇒ Сохранить).

Параметры заливки поверхности

Параметр Surface (Поверхность) в диалоговых окнах для эффектов Extrude & bevel (Вытягивание и скос) и Revolve (Вращение) позволяет выбрать один из следующих вариантов заливки поверхности:

• Wireframe (Каркас) — выводятся контуры геометрии объекта, все поверхности прозрачны;

• No Shading (Без тени) — объекту не добавляется новых свойств поверхности. Трехмерный объект имеет тот же цвет, что и исходный двухмерный объект;

• Diffuse Shading (Размытая тень) — делает отраженный от объекта свет мягким и размытым;

• Plastic Shading (Четкая тень) — объект отражает свет так, как если бы был сделан из материала с высоким блеском.

Примечание. В зависимости от выбранного варианта доступны различные параметры освещения. Если объект использует только эффект Rotate (Поворот), то для параметра Surface (Поверхность) доступны лишь варианты Diffuse Shading (Размытая тень) и No Shading (Без тени).

Проецирование символа на трехмерный объект

На трехмерный объект можно проецировать иллюстрации из Illustrator, а также импортировать иллюстрации из других приложений, например Photoshop.

Проецируемая иллюстрация должна представлять собой двухмерное изображение, сохраненное в палитре Symbols (Символы). Символами могут быть любые объекты Illustrator, в том числе контуры, составные контуры, текст, растровые изображения, сетчатые объекты и группы объектов. В этой части урока вы спроецируете на банку для содовой этикетку, которую сохранили как символ в предыдущей части урока.

1 Убедитесь, что фигура банки для содовой воды по-прежнему выделена. Щелкните по имени эффекта 3D Revolve (Вращение 3D-изображения) в палитре Appearance (Оформление). Перетащите в сторону диалоговое окно 3D Revolve Options (Параметры вращения 3D-изображения), чтобы видеть банку. Также убедитесь, что установлен флажок Preview (Просмотр).

2 Щелкните по кнопке Map Art (Проецирование) в диалоговом окне 3D Revolve Options (Параметры вращения 3D изображения).

При выполнении проецирования иллюстрации на трехмерный объект необходимо выбрать поверхность, на которую будет спроецирована иллюстрация. Каждый трехмерный объект состоит из нескольких поверхностей. Например, подвергнутый вытягиванию квадрат становится кубом, состоящим из шести поверхностей: передней и задней граней, а также четырех боковых граней. Сейчас вы выберете поверхность, на которую будет выполняться проецирование.

3 Перетащите диалоговое окно Map Art (Проецирование) в сторону. Выполняйте щелчки по кнопке Next Surface (Следующая поверхность) до тех пор, пока в поле ввода для поверхности не появится текст 4 of 4 (4 из 4). Обратите внимание, что на монтажной области отображается каркас объекта и выделенная поверхность подсвечивается красным цветом.

4 Выберите в раскрывающемся списке Symbol (Символ) этикетку содовой. Установите флажок Preview (Просмотр), если не сделали этого ранее.

Примечание. Если вы выбрали не ту поверхность, щелкните по кнопке Clear (Очистить) и выполните проецирование на другую поверхность.
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5 Сбросьте флажок Preview (Просмотр) в диалоговом окне Map Art (Проецирование), чтобы ускорить выполнение следующих шагов.

6 Перетащите символ в светлую частьсхемы в диалоговом окне Map Art (Проецирование). Светло-серым цветом помечены поверхности, которые видимы в настоящий момент. Темно-серым помечены поверхности, невидимые при текущем положении объекта.

Совет. Если вас не устраивает положение или размер символа, вы можете щелкнуть по кнопке Clear (Очистить) в нижней части диалогового окна, чтобы очистить текущую поверхность от символа.

7 Установите флажок Shade Artwork (Slower) (Реалистичные тени (медленно)). Поставьте флажок Preview (Просмотр), чтобы увидеть результат проецирования символа на объект, — возможно, вы захотите изменить положение или размер символа. После этого щелкните по кнопке OK, чтобы закрыть диалоговое окно Map Art (Проецирование).

8 В диалоговом окне 3D Revolve Options (Параметры вращения 3D-изображения) щелкните по кнопке Fewer Options (Меньше). Щелкните по левому краю синего квадрата и, не отпуская кнопку мыши, перемещайте указатель вправо, поворачивая трехмерный объект вокруг оси Y. Если установлен флажок Preview (Просмотр), то после того как вы отпустите кнопку мыши, изображение объекта на монтажной области обновится. Щелкните по кнопке OK.
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Теперь текстура обернута вокруг банки. Осталось отредактировать контур и цвет банки для содовой воды.

9 Выберите инструмент Selection (Выделение). Убедитесь, что выделен трехмерный объект. На панели Control (Управление) щелкните по кнопке Fill (Заливка) и измените ее цвет на черный. Обратите внимание, что вся фигура изменит свой цвет, за исключением того места, где на поверхность спроецирована иллюстрация символа. На данном этапе вы еще можете отредактировать исходную фигуру. Если вам необходимо повернуть трехмерный объект, это лучше всего сделать в диалоговом окне 3D Revolve Options (Параметры вращения 3D-изображения).

Совет. Вы можете работать с символами в диалоговом окне Map Art (Проецирование), используя обычные маркеры ограничительной рамки для перемещения, масштабирования и вращения объектов.

Проецирование иллюстрации на трехмерный объект

При проецировании иллюстраций на трехмерные объекты учитывайте следующее:

• поскольку для проецирования используются символы, можно отредактировать экземпляр символа, и он автоматически обновится на всех поверхностях, на которые был спроецирован;

• вы можете работать с символами в диалоговом окне Map Art (Проецирование), используя обычные маркеры ограничительной рамки для перемещения, масштабирования и вращения объектов;

• в объемном эффекте все поверхности объекта с проекциями запоминаются по номерам. При редактировании трехмерного объекта или применении тех же эффектов к новому объекту может оказаться, что сторон больше или меньше, чем у исходного объекта. Если поверхностей меньше, чем определено для исходного объекта, лишние иллюстрации игнорируются;

• поскольку символ занимает положение относительно центра поверхности объекта, при изменении геометрии поверхности символ будет спроецирован заново относительно нового центра;

• можно проецировать иллюстрации на объекты, использующие эффекты Extrude & bevel (Вытягивание и скос) и Revolve (Вращение), но нельзя проецировать иллюстрации на объекты, которые используют только эффект Rotate (Поворот).

Совет. При необходимости отредактировать исходную фигуру рекомендуется сначала в палитре Appearance (Оформление) отключить видимость для эффекта 3D Revolve (Mapped) (Вращение объемного изображения (Проецирование)).

10 Выполните команду меню View ⇒ Show Edges (Просмотр ⇒ Показать границы), чтобы отобразить границы для выполнения следующих заданий.

11 Выполните команду File ⇒ Save (Файл ⇒ Сохранить). Оставьте файл открытым для самостоятельной работы.
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