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Лекция. Клоны, пошаговые переходы, ореолы.

Клоны и клонирование эффектов.

Клоны представляют собой особый вариант совокупности копий объекта, которые, с одной стороны, могут размещаться индивидуально, а с другой стороны, одновременно меняют форму и атрибуты при редактировании всего лишь одного экземпляра из всего клона – мастера. Кроме клонов объектов в CorelDRAW предусмотрены особые клоны эффектов – например, теней и тел экструзии.

Основное свойство элемента клона состоит в том, что его нельзя редактировать. Элемент клона можно подвергать преобразованию: перемещать, поворачивать, зеркально отражать, но нельзя менять параметры его заливки и контурных линий, масштабировать, редактировать узлы. Все эти запрещенные для элемента клопа операции можно выполнять с управляющим объектом клона, причем все сделанные изменения автоматически распространяются на все элементы клона.

Как и элемент клона объекта, элемент клона эффекта тоже нельзя редактировать индивидуально, но он автоматически воспроизводит результат любой настройки эффекта для управляющего составного объекта клона эффекта.

Если перед клонированием выделить несколько объектов, то результатом будут являться несколько клонов, то есть каждый из выделенных объектов становится управляющим объектом собственного клона. При клонировании группы объектов она становится управляющей группой клона, элементами которого становятся не объекты, а группы-клоны. Разгруппирование такого элемента клона дает не элементы клонов отдельных объектов (этих клонов просто не существует), а самостоятельные объекты. Разгруппировать управляющую группу клона невозможно, пока существует хоть одна связанная с ней группа – элемент клона.

Элемент клона выделенного объекта создается командой Edit > Clone (Правка – Клонировать). По умолчанию он располагается с некоторым смещением по отношению к оригиналу.

Особенности поведения клонов

При работе с элементами и управляющими объектами клонов следует иметь в виду некоторые особенности их поведения, не присущие обычным копиям.
- При изменении какого-либо атрибута элемента клона связь этого элемента с управляющим объектом клона по данному атрибуту утрачивается. Предположим, что у нас имеется клон красного эллипса, включающий в себя три элемента, то есть еще три красных эллипса. Если изменить заливку одного из элементов клона на желтую, связь этого элемента с управляющим объектом клона по заливке будет разорвана (но сохранится по другим атрибутам). Если впоследствии управляющий эллипс будет масштабированием превращен в круг, а его заливка изменена с красной на синюю, то в клоне будет три круга: два синих и один желтый.
- При изменении размера элемента клона он утрачивает всякую связь с управляющим объектом клона, превращаясь в отдельный объект.
- При удалении управляющего объекта автоматически удаляются и все элементы его клона.
- При применении к управляющему объекту преобразований огибающей, перспективы, линз и прозрачности их действие распространяется и на элементы клона. Остальные преобразования и эффекты действуют только на управляющий объект.

Клонирование эффектов

Клонированием эффекта называется специальный вариант копирования эффекта с ранее созданного составного объекта (тела экструзии, пошагового перехода, тени, ореола) на другой объект, который будет играть роль управляющего в новом составном объекте. В этом случае элементом клона становится не весь составной объект, а только управляющие параметры его подчиненных объектов.
Эффекты клонируются приблизительно так же, как копируются с ранее созданных составных объектов, только вместо команды Effects > Copy Effect > ... From (Эффекты > Копировать эффект > ... с) или соответствующей ей кнопки панели атрибутов используется команда Effects > Clone Effect > ... From (Эффекты > Клонировать эффект > ... с).
Чтобы выполнить клонирование эффекта на объект (в случае эффекта пошагового перехода – на пару объектов), выделите его (их), раскройте меню Effects (Эффекты) и в подменю Clone Effect (Клонировать эффект) выберите одну из доступных команд клонирования эффектов. После этого указатель мыши изменит свой вид, превратившись в толстую стрелку. Щелкните этой стрелкой на составном объекте пошагового перехода, экструзии, ореола или отбрасываемой тени, который требуется клонировать.

При клонировании эффектов следует иметь в виду следующие особенности:

- Пошаговый переход клонируется командой Effects > Clone Effect > Blend From (Эффекты > Клонировать эффект > Пошаговый переходе). После клонирования все атрибуты управляющего составного объекта пошагового перехода будут применены к группе-элементу клона, за исключением атрибутов заливки. 
- Тело экструзии клонируется командой Effects > Clone Effect > Extrude From (Эффекты > Клонировать эффект > Экструзия с). Предварительно выделяется отдельный объект. Если вместо объекта выделяется группа или несколько объектов, команда клонирования эффекта недоступна.
- Ореол клонируется командой Effects – Clone Effect – Contour From (Эффекты – Клонировать эффект – Ореол с). Предварительно выделяется отдельный объект. Если вместо объекта выделяется группа или несколько объектов, команда клонирования эффекта недоступна. Новый элемент клона сохранит свои цвета заливки и обводки контура, но воспримет атрибуты контуров, составляющих управляющий ореол.
- Тень клонируется командой Effects > Clone Effect > Drop Shadow From (Эффекты > Клонировать эффект > Тень с). Предварительно нужно выделить объект или группу объектов. Новый элемент клона приобретет такую же тень, как управляющий объект.

Интерактивное перетекание

Перетеканием в CorelDRAW называется составной объект, содержащий начальный управляющий объект, конечный управляющий объект и упорядоченную совокупность промежуточных объектов. Форма промежуточных объектов подобрана так, чтобы их последовательность изображала этапы плавного преобразования начального управляющего объекта в конечный. Атрибуты заливки и обводки контура промежуточных объектов тоже плавно меняются. На рис. 11.6 перетекание наглядно иллюстрирует процесс превращения обезьяны в человека по Дарвину. 
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Рис. 11.6. Управляющие и промежуточные объекты пошагового перехода

У базового перетекание промежуточные объекты равномерно распределяются вдоль прямой, соединяющей центры управляющих объектов. В ходе последующей настройки можно отказаться от равномерности распределения, задав то или иное значение ускорения. Ускорением называется замена коэффициента пропорциональности, который используется для вычисления значений управляющих параметров промежуточного объекта в зависимости от номера этого объекта. Чаще всего ускорением пользуются для изменения расположения или скорости изменения заливки промежуточных объектов перетекания (рис. 11.7).
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Рис. 11.7. Влияние ускорения на расположение и заливку промежуточных объектов перетекания
Можно также отказаться от размещения промежуточных объектов вдоль прямой, указав для этого специальную траекторию (на роль которой обычно выбирается кривая). Впрочем, на рис. 11.8 для этой цели используется эллипс.
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Рис. 11.8. Размещение промежуточных объектов перетекания на эллиптической траектории(показана пунктиром)

Важным частным случаем перетекания является составное перетекание, которым называется составной объект, включающий в себя несколько перетеканий, разделяющих одни и те же управляющие объекты. Например, на рис. 11.9 представлено простейшее составное перетекание, в котором объекты в виде буквы Т двух различных гарнитур играют роли конечных управляющих объектов, а объект в форме круга является общим для обеих частей составного перетекания начальным объектом.
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Рис. 11.9. Составное перетекание и его построение

Работа с перетеканием начинается с построения управляющих объектов, назначения их атрибутов и размещения в желаемых положениях. Затем строится базовое перетекание.
1. Откройте панель интерактивных инструментов (рис. 11.10, справа внизу) и выберите инструмент Interactive Blend (Интерактивное перетекание).
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Рис. 11.10. Инструмент Interactive Blend и соответствующая ему панель атрибутов

2. Перетащите указатель инструмента от произвольной точки одного из управляющих объектов к произвольной точке второго управляющего объекта (см. рис. 11.9, вверху справа). При наведении указателя на любой из объектов рисунка, который может выступать в качестве управляющего, воспроизводятся промежуточные объекты будущего перетекания.

Который из двух управляющих объектов перехода будет начальным, зависит не от направления перетаскивания указателя инструментам, а от исходного расположения объектов в стопке. Начальным всегда становится объект, находящийся ниже. Если в процессе работы начальный объект оказывается в стопке выше конечного, они меняются ролями: конечный становится начальным, а начальный – конечным. 

Базовое перетекание строится со значениями управляющих параметров, принятыми по умолчанию: равномерное распределение 20 промежуточных объектов по прямой, соединяющей центры управляющих объектов, без ускорений. Далее построенный пошаговый переход можно настраивать с элементов управления панели атрибутов, представленных на рис. 11.10:
- С помощью раскрывающегося списка Preset List (Заготовки) можно выбрать заготовку перетекания.
- Поля координат центра перетекания позволяют точно размещать перетекание на рисунке.
- Поля габаритов перетекания позволяют придавать перетеканию точные габариты. 

- Кнопки Number of Steps (Число шагов перетекания) и Fixed Spacing (Интервал перетекания) служат для задания режима управления перетеканием. Если перетекание размещается по траектории, появляется возможность управлять количеством его промежуточных объектов, задавая расстояние между их центрами. Режим управления определяется тем, какая из двух кнопок нажата: верхняя соответствует числу объектов, нижняя – шагу. Если пошаговый переход не связан с траекторией, нижняя кнопка недоступна.

- Меняя значение счетчика Number of Steps (Число шагов перетекания), можно задавать количество промежуточных объектов перетекания.
- Счетчик Offset Between Blend Shapes (Смещение между формами) дает возможность задать расстояние вдоль траектории между двумя смежными промежуточными объектами для промежуточных объектов перетекания на траектории.
- Счетчик Blend Direction (Напавление перетекания) позволяет задавать угол разворота промежуточных объектов для перетекания, не связанных с траекторией. Значение счетчика указывает угол разворота последнего из промежуточных объектов. На рис. 11.11, а представлено перетекание с разворотом промежуточных объектов на 90°.
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Рис. 11.11. Пошаговые переходы с разворотом промежуточных объектов

- При нажатой кнопке Loop Blend (Перетекание циклом) дополнительный разворот промежуточных объектов выполняется не вокруг их центров, а вокруг общей для всех точки, расположенной посредине между центрами управляющих объектов (рис. 11.11, в).
- Кнопки Direct Blend (Прямое перетекание), Clockwise Blend (Перетекание по часовой стрелке) и Counterclockwise Blend (Перетекание против часовой стрелки) позволяют управлять последовательностью выбора цветов заливки промежуточных объектов пошагового перехода из цветового круга.

- Кнопка Object and Color Acceleration (Ускорение объектов и цветов) раскрывает вспомогательное диалоговое окно, содержащее два ползунка, позволяющих регулировать расстояния между промежуточными объектами пошагового перехода и скорость изменения цвета заливки промежуточных объектов. 
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Рис. 11.12. Влияние ускорения объектов и заливки на внешний вид пошагового перехода

- Кнопка Start and End Object Properties [image: image9.png]


 (Свойство начального и конечного объекта) раскрывает дополнительное меню с четырьмя командами:

• Show Start (Выделить начало). Эта команда сбрасывает выделение пошагового перехода и выделяет его начальный управляющий объект. 

• Show End (Выделить конец). Эта команда сбрасывает выделение пошагового перехода и выделяет его конечный управляющий объект.
• New Start (Новое начало). После выбора этой команды указатель мыши принимает форму стрелки с планкой. Этой стрелкой можно щелкнуть на любом объекте рисунка, после чего он становится начальным управляющим объектом пошагового перехода (конечный управляющий объект и все параметры настройки перехода при этом не меняются).
• New End (Новый конец). С помощью этой команды можно заменить конечный объект пошагового перехода.
Помимо уже знакомых нам кнопок копирования эффекта и его отмены, расположенных справа на панели атрибутов, не рассмотренными остались еще две кнопки – Miscellaneous Blend Options (Различные параметры перетекания) и Path Properties (Свойства пути). С ними мы познакомимся в следующих разделах. 
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Рис. 11.14. Управляющая схема перетекания
Управляющая схема становится видна после выделения любого из промежуточных объектов перетекания инструментом Interactive Blend (Интерактивное перетекание) или сразу по завершении построения перетекания.
Указатели управляющих объектов представлены белыми квадратными маркерами. В указатель конечного управляющего объекта «втыкается» треугольник, символизирующий направление перетекания. Прямая, вдоль которой располагаются промежуточные объекты, показана цветной штриховой линией. Над этой линией находится синий треугольный ползунок. Его положение связано с величиной управляющего параметра ускорения объектов. Перетаскивая ползунок вдоль пунктирной линии, можно задавать ускорение. Под штриховой линией располагается красный треугольный ползунок ускорения заливки.
Перетекание вдоль заданной траектории

Перетекание вдоль заданной траектории используют, когда требуется разместить объекты перетекания вдоль замкнутой или незамкнутой кривой. При этом кривая включается в составной объект типа «перетекание» на правах еще одного (третьего) управляющего объекта. Построение перетекания на траектории выполняется следующим образом.
1. Постройте кривую, которая будет играть роль траектории.
2. Постройте базовое перетекание.
3. Не сбрасывая выделения пошагового перехода, щелкните на кнопке Path Properties Свойства пути) панели атрибутов и выберите в раскрывшемся меню команду New Path (Новый путь).
4. Щелкните появившимся указателем в виде искривленной стрелки на ранее построенной траектории. Перетекание окажется привязанным к траектории, и центры его промежуточных объектов расположатся на ней.
После того как перетекание привязывается к траектории, перемещение его управляющих объектов мышью ограничивается – перетаскивание объекта приводит только к перемещению центра управляющего объекта в пределах траектории. Если объекты перетекания следует разместить вдоль всей длины траектории, сделайте следующее.
1. Выделите пошаговый переход, щелкнув указателем инструмента Pick (Указатель) на любом из его промежуточных объектов.
2. Щелчком на кнопке Miscellaneous Blend Options (Различные параметры перетекания) панели атрибутов раскройте вспомогательное диалоговое окно.
 3. Установите флажок Blend Along Full Path (Перетекание вдоль пути).

Чтобы угол поворота промежуточных объектов соответствовал наклону траектории, можно включить режим разворота всех промежуточных объектов.
1. Выделите пошаговый переход, щелкнув указателем инструмента Pick (Указатель) на любом из его промежуточных объектов.
2. Щелчком на кнопке Miscellaneous Blend Options (Различные параметры перетекания) панели атрибутов раскройте вспомогательное диалоговое окно.
3. Установите флажок Rotate All Objects (Вращать все объекты).

Составные и разделенные перетекания
Составное перетекание получается при построении нового перетекания, один из управляющих объектов которого играет роль управляющего объекта уже существующего перетекания. При разделении перетекания один из промежуточных объектов становится конечным управляющим для одного и начальным управляющим для второго из перетеканий, порождаемых исходным. На рис. 11.17 представлены примеры составных перетеканий. Чтобы построить составное перетекание, необходимо заранее подготовить базовое перетекание (которое будет играть роль части составного пертекания) и управляющий объект. Управляющий объект следует разместить в стопке объектов так, чтобы новый сегмент перетекания выглядел как задумано – напомним, что направление перетекания и, соответственно, последовательность размещения его промежуточных объектов зависят от взаимного расположения его управляющих объектов в стопке. После этого остается только выбрать инструмент Interactive Blend (Интерактивное перетекание) и перетащить его указатель от отдельного объекта к одному из управляющих объектов ранее существовавшего перетекания. На рис. 11.18 представлен составное перетекание, изображающее стержень переменного диаметра, и отдельно – его управляющие объекты. В каждой из частей составного пошагового перехода – 200 промежуточных объектов, что вполне достаточно для отчетливого воспроизведения полосатой раскраски трубы.
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Рис. 11.17. Составные пошаговые действия
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Рис. 11.18. Составной пошаговый переход, включающий в себя четыре пошаговых перехода. 

Установка параметров перетекания может выполняться раздельно для каждой из частей составного перетекания. Для этого следует отдельно выделить часть перетекания, щелкнув на любом из промежуточных объектов указателем инструмента Pick (Указатель) при нажатой клавише Ctrl. После этого можно задавать управляющие параметры описанными выше приемами. Отдельные части составного перетекания могут привязываться к траекториям – как к одной и той же, так и к разным. На рис. 11.19 показано, что две последние части составного перетекания привязаны к траектории.
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Рис. 11.19. Две части составного пошагового перехода привязаны к криволинейной траектории

Но к разным траекториям могут привязываться только несмежные части составного пошагового перехода.
Чтобы разделить перетекание (или часть составного перетекания), следует выделить его, а затем щелкнуть на кнопке Split (Разъединить) во вспомогательном диалоговом окне, раскрывающемся щелчком на кнопке Miscellaneous Blend Options (Различные параметры перетекания) панели атрибутов. На месте указателя мыши появится изогнутая стрелка, которой следует щелкнуть на любом из промежуточных объектов перетекания. После этого данный объект станет начальным для одной и конечным для второй из частей созданного разделенного перетекания.
 Промежуточные управляющие объекты разделенного перетекания, так же как в случае составного перетекания, можно перемещать, поворачивать, редактировать их форму (для них это возможно только при определенном положении управляющих объектов в стопке). Но, в отличие от составного перетекания, разделенное перетекание можно возвратить в исходное состояние, лишив промежуточный управляющий объект временно приданного ему статуса управляющего. Для этого достаточно отдельно выделить часть разделенного перетекания (щелкнув на любом из ее промежуточных объектов при нажатой клавише Ctrl), раскрыть щелчком на кнопке Miscellaneous Blend Options (Различные параметры перетекания) панели атрибутов вспомогательное диалоговое окно и щелкнуть в нем на кнопке Fuse Start (Соединить начало) или Fuse End (Соединить конец).
Имитация объемных тел с помощью интерактивного перетекания и градиентной заливки их управляющих объектов позволяет добиваться замечательных эффектов, но в то же время требует выполнения огромного объема вычислений, поэтому на промежуточных этапах настройки целесообразно воспользоваться режимом отображения Wireframe (Каркас).
Перетекания с незамкнутыми управляющими объектами

В отдельных случаях целесообразно применить перетекание, построенное на базе незамкнутых управляющих объектов. На рис. 11.20 представлено перетекание, построенный на базе двух копий пятивитковой спирали.
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Рис. 11.20. Пошаговый переход с незамкнутыми управляющими объектами

Верхняя спираль представляет собой смещенную вверх копию нижней. Для нижней задана обводка черной контурной линией толщиной 16 пунктов, для верхней – белой контурной линией толщиной 2 пункта. Кроме того, центр белой спирали дополнительно смещен вверх в режиме эластичного сдвига. Перетекание построено с 40 промежуточными объектами, в результате получилось что-то среднее между часовой пружиной и горной дорогой.
Разъединение пошаговых переходов

Зачастую построение и последующая настройка перетекания не позволяют добиться желаемого результата. В этом случае можно воспользоваться перетеканием как полуфабрикатом, разбив его для окончательной настройки на отдельные объекты.
После выделения перетекания инструментом Pick (Указатель) сообщение в строке состояния говорит о том, что выделена группа перетекания. Команда Arrange > Break Blend Group Apart (Упорядочить – Разъединить Группа с перетеканием) разрушает группу перетекания, и связь ее компонентов друг с другом утрачивается. После этого перетекание превращается в совокупность из двух отдельных объектов (ранее бывших управляющими) и группы промежуточных объектов. Группу промежуточных объектов можно разгруппировать, чтобы работать с каждым из них отдельно.
Упражнение. Разделение перетекания на отдельные объекты

В этом упражнении мы освоим на практике приемы разделения перетекания для индивидуальной настройки промежуточного управляющего объекта и отделения перетекания для окончательной корректировки положений промежуточных объектов. В качестве объекта для изображения выберем бусы, в средней части которых расположены 7 миндалевидных бусин, размер которых постепенно уменьшается по мере удаления от центра. Вслед за ними идут еще по пять круглых бусин одинакового диаметра с каждой стороны.
Последовательность выполнения упражнения иллюстрирует рис. 11.21.
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Рис. 11.21. Последовательность построения изображения нитки с бусинами различных размеров и форм

1. Начните с изображения нити, на которой будут располагаться бусины. Если подходить к вопросу строго, то следовало бы построить так называемую цепную линию, но для целей иллюстративной графики ее с успехом заменит вытянутый по вертикали эллипс. Затем постройте еще один эллипс, на этот раз – вытянутый по горизонтали и с размерами самой маленькой из продолговатых бусин. Продублируйте его, сместите копию вправо и постройте на базе двух маленьких эллипсов пошаговый переход с пятью промежуточными объектами. После того как вы привяжете его к траектории, задаваемой эллипсом, должно получиться что-то вроде нитки на рис. 11.21, а.

Чтобы средняя бусина пошагового перехода попала точно в середину нитки, постройте вертикальную направляющую, проходящую через центр эллипса, и перемещайте управляющие объекты перехода, добиваясь желаемого расположения средней бусины. Для удобства можно построить и горизонтальную направляющую, чтобы выровнять по ней центры управляющих объектов.

2. Разделите пошаговый переход, превратив среднюю бусину в управляющий объект. Выделите ее инструментом Pick (Указатель) и увеличьте до желаемых размеров с помощью полей панели атрибутов. При этом неизбежно возникнет перекрытие промежуточных объектов (рис. 11.21, б) – на него мы пока не обращаем внимания.
3. Выделите инструментом Pick (Указатель) крайнюю правую продолговатую бусину и перетащите ее вправо и вверх по нитке, устраняя в первом приближении перекрытие промежуточных объектов. Повторите щелчок мышью, чтобы появились маркеры поворота. Поверните бусину вокруг центра вращения (который расположен на линии, изображающей нитку) таким образом, чтобы нитка «пронизывала» ее по длинной оси эллипса. Проделайте то же с левой крайней бусиной. Как бы мы ни старались, угол поворота остальных промежуточных объектов при этом будет весьма далек от желаемого. Кроме того, устранить перекрытие промежуточных объектов, не допустив возникновения зазоров между ними, пользуясь только регуляторами ускорения промежуточных объектов, скорее всего, не удастся – изображение нитки на рис. 11.21, в несет на себе следы не увенчавшихся успехом попыток такого рода. Стремиться к абсолютной точности поворота бусин и их расположения на этом этапе нет необходимости.

4. Отдельно выделив правую часть составного пошагового перехода, выполните разъединение командой Arrange > Break Blend Group Apart (Упорядочить – Разъединить Группа с перетеканием), затем разгруппируйте полученную группу промежуточных объектов. Выделите инструментом Pick (Указатель) бусину, расположенную справа от центральной, и перетащите средний маркер до полного устранения зазора и перекрытия с центральной бусиной. Выполнив второй щелчок, откорректируйте угол ее поворота. Поступите также со всеми остальными бусинами правой половины нитки, начиная от середины к краю, а затем повторите весь процесс для левой половины нитки. После этого все бусины должны занять свои места (рис. 11.21, г). Оставшиеся минимальные погрешности расположения бусин не должны вас смущать — в настоящих бусах каждая бусина все равно просверливается не идеально по геометрической оси, кроме того, такие погрешности на глаз почти не воспринимаются.
5. Остается только построить два пошаговых перехода, изображающих круглые бусины, разместить их на той же кривой, откорректировать положение управляющих объектов и шаг промежуточных объектов (рис. 11.21, д). Заключительный штрих – назначение текстурной заливки (рис. 11.21, е).

Контуры

Контур представляет собой совокупность замкнутых кривых, подобных управляющему объекту и отстоящих на одинаковом расстоянии от него. Цвета заливки и обводки управляющего объекта плавно перетекают в цвета заливки и обводки, заданные для последнего из объектов контура. Количество подчиненных объектов в ореоле указывается явно или определяется автоматически. Ореолы во многом аналогичны перетеканию, но в ореоле второй управляющий объект (подобный первому) лишь подразумевается.
В качестве управляющего объекта ореола могут выступать только отдельные объекты – как замкнутые, так и незамкнутые, – но не группы и не совокупности совместно выделенных объектов.
На рис. 11.22 представлены три примера ореолов, в которых в качестве управляющих объектов используются звезда, произвольная незамкнутая кривая и криволинейный объект (фигура мужчины, взятая из библиотеки стандартных фрагментов).
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Рис. 11.22. Примеры ореолов

В CorelDRAW поддерживаются три типа контуров: наружный (рис. 11.23, а), внутренний (рис. 11.23, б), до центра (рис. 11.23, в), отличающихся друг от друга способом размещения подчиненных объектов по отношению к управляющему и методом определения количества этих объектов.
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Рис. 11.23. Типы ореолов

Во всех трех случаях в качестве управляющего объекта использовался пятиугольник с темной заливкой.

 В наружном контуре габариты подчиненных объектов превышают габариты последнего и возрастают, следовательно, их контуры охватывают контур управляющего объекта снаружи. Управляющими параметрами наружного ореола являются количество подчиненных объектов и величина шага ореола (расстояние между абрисами смежных подчиненных объектов).
У внутреннего контура габариты подчиненных объектов меньше габаритов последнего и убывают, следовательно, их контуры вложены в контур управляющего объекта. Число и назначение управляющих параметров внутреннего ореола те же, что и у наружного.
В отличие от наружного ореола при построении внутреннего ореола место для размещения подчиненных объектов ограничено, и если совокупность заданных управляющих параметров требует такого числа подчиненных объектов, что они просто не поместились бы внутри управляющего объекта, параметр количества игнорируется. 

Центральный контур представляет собой частный случай внутреннего ореола. Он отличается от него только тем, что управляющий параметр количества шагов ореола сразу игнорируется и подчиненные объекты заполняют с заданным шагом все внутреннее пространство управляющего объекта.
Так же как другие рассмотренные ранее в этой главе эффекты, эффект контура можно копировать и клонировать.
Чтобы построить базовый ореол, следует выполнить описанную ниже процедуру:
1. Выделите будущий управляющий объект контура инструментом Pick (Указатель).
2. Раскройте панель интерактивных инструментов и щелкните на кнопке инструмента Interactive Contour (Интерактивный контур). Панель с нажатой кнопкой этого инструмента представлена на рис. 11.24, слева внизу.
3. Перетащите указатель инструмента в направлении от центра управляющего объекта. В процессе перетаскивания на экране появляется управляющая схема. Точка завершения перетаскивания определяет положение последнего из подчиненных объектов ореола.
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Рис. 11.24. Инструмент Interactive Contour и соответствующая ему панель атрибутов

После построения базового контура можно приступать к его настройке с помощью элементов управления, расположенных на панели атрибутов инструмента Interactive Contour (Интерактивный контур).

- Нажатая кнопка в группе из трех кнопок То Center (К центру), Inside (Внутри) и Outside (За пределами) определяет тип контура – соответственно центральный, внутренний или наружный. Нажатие другой кнопки из этой группы приводит к смене типа контура и перестраиванию всех его подчиненных объектов.
- Счетчик Contour Steps (Шаги контура) задает количество подчиненных объектов (шагов контура) для наружного и внутреннего типов контура.
- Счетчик Contour Offset (Смещение контура) задает расстояние между абрисами двух последовательных подчиненных объектов контура. Для центральных и внутренних контуров введенное значение не может превышать расстояния от самой удаленной точки абриса управляющего объекта до его центра.
- Раскрывающиеся палитры Outline Color (Цвет абриса) и Fill Color (Цвет заливки) определяют цвета последнего из подчиненных объектов контура. Цвета контурных линий и заливки остальных объектов контура определяются как промежуточные между выбранными в этих палитрах и цветами управляющего объекта контура.
- Группа кнопок управления переходом цвета заливки – Linear Contour Colors (По прямой), Clockwise Contour Colors (По часовой) и Counterclockwise Contour Colors (Против часовой) – позволяет управлять последовательностью выбора цветов заливки подчиненных объектов ореола из цветового круга.
- Раскрывающаяся палитра End Fountain Fill Color (Конечный цвет градиентной заливки) доступна, когда управляющему объекту ореола назначена градиентная заливка. В этом случае управляющая схема заливки распространяется на все подчиненные объекты, но с заменой начального и конечного цветов. Начальный цвет градиентной заливки выбирается в раскрывающейся палитре Outline Color (Цвет обводки), а конечный – в раскрывающейся палитре End Fountain Fill Color (Конечный цвет градиентной заливки).
- Кнопка Object and Color Acceleration (Ускорение объектов и цветая) раскрывает вспомогательное диалоговое окно, элементы управления которого, так же как и в случае перетекания (см. выше), позволяют настраивать размещение и способ выбора цвета для промежуточных объектов группы ореола.
С появлением в CorelDRAW возможности преобразовывать контурные линии объектов в самостоятельные объекты область практического применения контуров несколько сократилась, но иногда контурами пользоваться все-таки удобнее. Так, интересные эффекты дает применение контуров к текстовым объектам. Например, с помощью контура, состоящего из единственного подчиненного объекта с белой заливкой без обводки, можно зрительно выделить надпись: на рис. 11.25, а показан объект без контура, на рис. 11.25, б – узкий контур, на рис. 11.25, в — широкий контур.
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Рис. 11.25. Ореолы с текстовыми управляющими объектами

Контуры можно разбивать на независимые объекты тем же способом, что пошаговые переходы, и впоследствии настраивать бывшие подчиненные объекты индивидуально.

